AIX

Last updated on 17 March, 2023

Depending on your version and configuration of AIX, the file that controls SNMP differs.  Check whether /usr/sbin/snmpd is linked to /usr/sbin/snmpdv3ne:

cd /usr/sbin
ls -al snmpd
lrwxrwxrwx   1 root     system            9 Oct 31 2006  snmpd -> snmpdv3ne

If it is linked to snmpdv3ne or snmpdv3e, then the relevant config file is /etc/snmpdv3.conf, not /etc/snmpd.conf.  (The active snmp agent is controlled by snmpv3_ssw. snmpv3_ssw -n will switch to the non-encrypted, v3 agent.)

To allow AIX monitoring, you just need to ensure that the config file (snmpd.conf or /etc/snmpdv3.conf) allows the LogicMontor collector to query the system.  
Ensure that the collector has access with the community you expect, and that all views are included.
  Ensure that any line such as:

VACM_VIEW defaultView 1.3.6.1.4.1.2.6.191 - excluded -

is changed to included:

VACM_VIEW defaultView 1.3.6.1.4.1.2.6.191 - included -

Then restart all the snmp services:

stopsrc -s snmpd;stopsrc -s dpid2;stopsrc -s aixmibd;stopsrc -s hostmibd;stopsrc -s snmpmibd
startsrc -s snmpd;startsrc -s dpid2;startsrc -s aixmibd;startsrc -s hostmibd;startsrc -s snmpmibd

If you are not receiving data for CPU, memory, etc:

Ensure hostmibd, snmpmibd and aixmibd are not commented out in /etc/rc.tcpip

Ensure that snmp configuration allows connections from 127.0.0.1 with public community (or the appropriate community if you’ve changed that used by aixmibd away from the default.) (Note: the subdaemon’s actually connect to hostname “loopback” – so make sure that correctly resolves to 127.0.0.1)

Ensure aixmibd is running: lssrc -s aixmibd

Check /var/tmp/aixmibd.log to see whether aixmibd has correctly registered with the snmpd system, and for clues as to why not.

Sample /etc/snmpdv3.conf:

VACM_GROUP group1 SNMPv1  public  -

#VACM_VIEW defaultView       internet                   - included - 
VACM_VIEW defaultView        1.3.6.1.4.1.2.2.1.1.1.0    - included - 
VACM_VIEW defaultView        1.3.6.1.4.1.2.6.191.1.6    - included -

# include normally excluded snmpv3 related MIBs from the default view
VACM_VIEW defaultView        snmpModules                - included - 
VACM_VIEW defaultView        1.3.6.1.6.3.1.1.4          - included - 
VACM_VIEW defaultView        1.3.6.1.6.3.1.1.5          - included -

# include normally excluded aixmibd managed MIBs from the default view 
VACM_VIEW defaultView        1.3.6.1.4.1.2.6.191        - included - 
VACM_VIEW defaultView 1.3.6.1.2.1.25.2.3.1 - included - 
VACM_VIEW defaultView 1.3.6.1.2.1.25.2.3.1.3 - included - 
VACM_VIEW defaultView 1.3.6.1.2.1 - included - 
VACM_VIEW defaultView 1.3.6.1.4.1.2021 - included -

VACM_ACCESS  group1 - - noAuthNoPriv SNMPv1  defaultView - defaultView -

NOTIFY notify1 traptag trap -

TARGET_ADDRESS Target1 UDP 127.0.0.1       traptag trapparms1 - - -

TARGET_PARAMETERS trapparms1 SNMPv1  SNMPv1  public  noAuthNoPriv -

COMMUNITY public    public     noAuthNoPriv 0.0.0.0 0.0.0.0 - 
DEFAULT_SECURITY no-access - -

logging         file=/usr/tmp/snmpdv3.log       enabled 
logging         size=100000                     level=0

smux            1.3.6.1.4.1.2.3.1.2.1.2         gated_password  # gated 
VACM_GROUP director_group SNMPv2c public  -

VACM_ACCESS director_group - - noAuthNoPriv SNMPv2c defaultView - defaultView -

AIX Monitoring with the net-snmp agent

The native AIX snmp daemon is not easily extended, and doesn’t report some things as well as the net-snmp agent. However, the net-snmp agent cannot report some things about AIX systems. Thus if you want to run the net-snmp snmpd, we recommend you configure the AIX agent to receive some requests proxied from the net-snmp version of snmpd.

You need to run the IBM snmpd on a different port:

chssys -s snmpd -a '-p 1610'
stopsrc -s snmpd;stopsrc -s dpid2;stopsrc -s aixmibd
stopsrc -s hostmibd;stopsrc -s snmpmibd
startsrc -s snmpd;startsrc -s dpid2;startsrc -s aixmibd
startsrc -s hostmibd;startsrc -s snmpmibd

Install net-snmp daemon, or compile from source. For drive performance monitoring, ensure you compile with the option: –with-mib-modules=ucd-snmp/diskio. For example, enter:

./configure --prefix=/usr/local/net-snmp --with-mib-modules=if-mib --enable-mfd-rewrites --without-kmem-usage --enable-ipv6 --enable-embedded-perl --enable-shared --with-mib-modules=ucd-snmp/diskio --without-perl-modules

Add these lines to your snmpd.conf (the one used by the net-snmp snmp daemon, not the AIX snmpd.conf in /etc/)

# Proxy IBM Agent Requests for port number
proxy -v 1 -c public 127.0.0.1:1610 1.3.6.1.4.1.2.2.1.1.0
proxy -v 1 -c public 127.0.0.1:1610 1.3.6.1.4.1.2.2.1.1.1.0
# Proxy iftable(IF-MIB: Interface Names & Stats), iptable and ifalias
proxy -v 1 -c public 127.0.0.1:1610 .1.3.6.1.2.1
proxy -v 1 -c public 127.0.0.1:1610 .1.3.6.1.2.1.4.20.1
# Proxy RFC1213-MIB (Route Info)
proxy -v 1 -c public 127.0.0.1:1610 .1.3.6.1.2.1.4.21.1
# Proxy SysUptime (netsnmp doesn't work)
proxy -v 1 -c public 127.0.0.1:1610 1.3.6.1.2.1.25.1.1.0
# Proxy the SNMP Descr so OS shows up properly
proxy -v 1 -c public 127.0.0.1:1610 .1.3.6.1.2.1.1.1.0
proxy -v 1 -c public 127.0.0.1:1610 .1.3.6.1.2.1.1.2.0
# Proxy paging spaces
proxy -v 1 -c public 127.0.0.1:1610 .1.3.6.1.4.1.2.6.191.2.4.2.1

Lastly, start the new snmpd with the flags snmpd -I -interfaces, and you should be good to go.

./snmpd -I -interfaces

You should configure the net-snmp snmpd daemon to start on system boot.

Troubleshooting

If you still cannot add your host, you may want to try adding just a single proxy configuration line, instead:

proxy -v 1 -c public 127.0.0.1:1610

If you are not getting Disk Usage- metrics, you may need to update your Servers() function, and/or manually add “AIX” to your device’s system.categories.

In This Article