Overview

On October 22, 2020, during the routine maintenance window, LogicMonitor will retire support for an older Transport Layer Security (TLS) cipher suite as well as support for the 1.1 version of the TLS protocol. We are retiring this TLS protocol to align with current best practices for high security environments.

Avoiding Potential Operational Impacts

While we expect this change to have no noticeable impacts for the majority of customers, there is a possibility that retirement of TLS 1.1 could affect one or more areas of your LogicMonitor operations. In the following sections, we’ve highlighted the operations that could be impacted and created an easy checklist to help you avoid any unexpected impacts.

Collector Operations

Confirm all Collectors are running MGD version 28.005 (or higher)

Collector versions 28.005 (or higher) support TLS 1.2. If you have one or more Collectors that have not yet been upgraded to this minimum version, please contact technical support.

LogicMonitor has released the LogicMonitor_Collector_TLSVersion DataSource (locator code 4EKHHE) for import that you can use to confirm all of your installed Collectors are capable of handling TLS 1.2. This DataSource initiates an HTTPS connection and verifies the negotiated TLS version, alerting you if a TLS 1.2 connection cannot be successfully made.

Note: In order for this DataSource to perform correctly, a Collector host must be monitored as a resource that references itself as its own preferred Collector.

Network Proxy Configurations

Ensure applicable network proxy software supports TLS 1.2

If any of your Collectors or web browsers have been configured to use network proxies, ensure the proxy software supports TLS 1.2.

REST API Access

Verify scripts utilizing LogicMonitor’s REST API are capable of supporting TLS 1.2

If you have written scripts or programs to interface with our REST API, they must be able to support TLS v1.2 or higher. Many languages are dependent upon OpenSSL which has supported TLS 1.2 since 2012.

Web Browser Support

Ensure users of your LogicMonitor portal are using current browsers

Although it’s unlikely for a user’s browser version to cause any issues as TLS 1.2 has been available in all major web browsers for upwards of five years, next we’ve listed minimum required versions (and their release years) for all browsers supported by LogicMonitor.

  • Google Chrome version 29 (2013)
  • Mozilla Firefox version 27 (2014)
  • Microsoft Edge (all versions)
  • Apple Safari version 7 (2013)

In this Article: